转化快应用的时候提示 错误 包安装 缺少包 @tarojs/components-qa,请安装!



  • 转化快应用的时候提示 错误 包安装 缺少包 @tarojs/components-qa,请安装!
    请问怎么安装这个包 呢



  • @jd_4ac9f2e5e1ecf 估计是你创建模版的时候版本比较低,现在你新建一个模版,然后把package.json里的依赖复制过去安装一下咯。



  • 是从微信小程序转过来的,转别的没问题,只有快应用才会出现这个问题,试了好几次都不行



  • @jd_4ac9f2e5e1ecf 嗯,一样的。

    {
      "name": "packagesTest",
      "version": "1.0.0",
      "private": true,
      "description": "packagesTest",
      "templateInfo": {
        "name": "default",
        "typescript": false,
        "css": "sass"
      },
      "scripts": {
        "build:weapp": "taro build --type weapp",
        "build:swan": "taro build --type swan",
        "build:alipay": "taro build --type alipay",
        "build:tt": "taro build --type tt",
        "build:h5": "taro build --type h5",
        "build:rn": "taro build --type rn",
        "build:qq": "taro build --type qq",
        "build:quickapp": "taro build --type quickapp",
        "dev:weapp": "npm run build:weapp -- --watch",
        "dev:swan": "npm run build:swan -- --watch",
        "dev:alipay": "npm run build:alipay -- --watch",
        "dev:tt": "npm run build:tt -- --watch",
        "dev:h5": "npm run build:h5 -- --watch",
        "dev:rn": "npm run build:rn -- --watch",
        "dev:qq": "npm run build:qq -- --watch",
        "dev:quickapp": "npm run build:quickapp -- --watch"
      },
      "author": "",
      "license": "MIT",
      "dependencies": {
        "@tarojs/components": "1.3.12",
        "@tarojs/router": "1.3.12",
        "@tarojs/taro": "1.3.12",
        "@tarojs/taro-alipay": "1.3.12",
        "@tarojs/taro-h5": "1.3.12",
        "@tarojs/taro-qq": "1.3.12",
        "@tarojs/taro-quickapp": "1.3.12",
        "@tarojs/taro-swan": "1.3.12",
        "@tarojs/taro-tt": "1.3.12",
        "@tarojs/taro-weapp": "1.3.12",
        "nervjs": "^1.4.0",
        "nerv-devtools": "^1.4.0"
      },
      "devDependencies": {
        "@types/react": "^16.4.6",
        "@types/webpack-env": "^1.13.6",
        "@tarojs/plugin-babel": "1.3.12",
        "@tarojs/plugin-csso": "1.3.12",
        "@tarojs/plugin-sass": "1.3.12",
        "@tarojs/plugin-uglifyjs": "1.3.12",
        "@tarojs/webpack-runner": "1.3.12",
        "babel-plugin-transform-class-properties": "^6.24.1",
        "babel-plugin-transform-decorators-legacy": "^1.3.4",
        "babel-plugin-transform-jsx-stylesheet": "^0.6.5",
        "babel-plugin-transform-object-rest-spread": "^6.26.0",
        "babel-preset-env": "^1.6.1",
        "babel-eslint": "^8.2.3",
        "eslint": "^5.16.0",
        "eslint-config-taro": "1.3.12",
        "eslint-plugin-react": "^7.8.2",
        "eslint-plugin-react-hooks": "^1.6.1",
        "eslint-plugin-import": "^2.12.0",
        "stylelint": "9.3.0",
        "stylelint-config-taro-rn": "1.3.12",
        "stylelint-taro-rn": "1.3.12",
        "eslint-plugin-taro": "1.3.12"
      }
    }
    
    

    把里面的scripts,dependencies 字段里的依赖同步一下咯



  • 按照你说的更新了之后还是报相同的问题,59841288-a6d4-4acf-ba32-b0bfcb822306-image.png





  • 可以了,谢谢


登录后回复