taro ui安装报错



  • node version 10.16.3
    taro-cli安装,没用ts,没css预处理器,默认模版。在初始化的工程下,安装taro-cli,报下面的错,是版本问题吗:

    npm WARN enoent SKIPPING OPTIONAL DEPENDENCY: ENOENT: no such file or directory, rename 'D:\code\jingdong-web\node_modules.staging\fsevents-3beb7add\node_modules\abbrev' -> 'D:\code\jingdong-web\node_modules.staging\abbrev-645f1737'

    npm ERR! code ENOENT
    npm ERR! syscall rename
    npm ERR! path D:\code\jingdong-web\node_modules\object.assign\node_modules\object-keys
    npm ERR! dest D:\code\jingdong-web\node_modules\define-properties\node_modules\object-keys
    npm ERR! errno -4058
    npm ERR! enoent ENOENT: no such file or directory, rename 'D:\code\jingdong-web\node_modules\object.assign\node_modules\object-keys' -> 'D:\code\jingdong-web\node_modules\define-properties\node_modules\object-keys'
    npm ERR! enoent This is related to npm not being able to find a file.
    npm ERR! enoent

    npm ERR! A complete log of this run can be found in:
    npm ERR! C:\Users\sigezhao\AppData\Roaming\npm-cache_logs\2019-10-13T12_22_56_860Z-debug.log

    package.json文件内容:

    {
      "name": "jingdong-web",
      "version": "1.0.0",
      "private": true,
      "description": "jingdong web",
      "templateInfo": {
        "name": "default",
        "typescript": false,
        "css": "none"
      },
      "scripts": {
        "build:weapp": "taro build --type weapp",
        "build:swan": "taro build --type swan",
        "build:alipay": "taro build --type alipay",
        "build:tt": "taro build --type tt",
        "build:h5": "taro build --type h5",
        "build:rn": "taro build --type rn",
        "build:qq": "taro build --type qq",
        "build:quickapp": "taro build --type quickapp",
        "dev:weapp": "npm run build:weapp -- --watch",
        "dev:swan": "npm run build:swan -- --watch",
        "dev:alipay": "npm run build:alipay -- --watch",
        "dev:tt": "npm run build:tt -- --watch",
        "dev:h5": "npm run build:h5 -- --watch",
        "dev:rn": "npm run build:rn -- --watch",
        "dev:qq": "npm run build:qq -- --watch",
        "dev:quickapp": "npm run build:quickapp -- --watch"
      },
      "author": "",
      "license": "MIT",
      "dependencies": {
        "@tarojs/components": "1.3.19",
        "@tarojs/router": "1.3.19",
        "@tarojs/taro": "1.3.19",
        "@tarojs/taro-alipay": "1.3.19",
        "@tarojs/taro-h5": "1.3.19",
        "@tarojs/taro-qq": "1.3.19",
        "@tarojs/taro-quickapp": "1.3.19",
        "@tarojs/taro-swan": "1.3.19",
        "@tarojs/taro-tt": "1.3.19",
        "@tarojs/taro-weapp": "1.3.19",
        "nervjs": "^1.4.0",
        "nerv-devtools": "^1.4.0"
      },
      "devDependencies": {
        "@types/react": "^16.4.6",
        "@types/webpack-env": "^1.13.6",
        "@tarojs/plugin-babel": "1.3.19",
        "@tarojs/plugin-csso": "1.3.19",
        "@tarojs/plugin-uglifyjs": "1.3.19",
        "@tarojs/webpack-runner": "1.3.19",
        "babel-plugin-transform-class-properties": "^6.24.1",
        "babel-plugin-transform-decorators-legacy": "^1.3.4",
        "babel-plugin-transform-jsx-stylesheet": "^0.6.5",
        "babel-plugin-transform-object-rest-spread": "^6.26.0",
        "babel-preset-env": "^1.6.1",
        "babel-eslint": "^8.2.3",
        "eslint": "^5.16.0",
        "eslint-config-taro": "1.3.19",
        "eslint-plugin-react": "^7.8.2",
        "eslint-plugin-react-hooks": "^1.6.1",
        "eslint-plugin-import": "^2.12.0",
        "stylelint": "9.3.0",
        "stylelint-config-taro-rn": "1.3.19",
        "stylelint-taro-rn": "1.3.19",
        "eslint-plugin-taro": "1.3.19"
      }
    }
    

登录后回复